Having some issue deploying project

0

My first time with WM and so far it looks really powerful!

I have created a DB app using postgres and it works in WM. I have PostgreSQL/Apache PHP that I disabled to run Tomcat (could not get WM to deploy the war to APHP but I will need that to do the postgis implementation later. I will be setting up the Coyote connector to the APHP/Tomcat install at some point but need to get the initial testing done first with WM.

Anyway, the issue I am having is with the ‘deploy to server’ feature. I cannot deploy using WM, I get an alert for manager, and I have Tomcat setup with a Name and PW. I tried localhost and the host name.

On the other hand, I was able to use the Tomcat ‘war deploy’ with some success. I can use the app on the localhost:8080, however, if I try to access from external boxes I get a 404 ‘The requested resource() is not available’ error to that page. I can access everything else on the Tomcat box, so that is working fine. I am sure that this is some simple config issue but I am not really versed in Tomcat conf files.

Any thoughts?

edc's picture

Deployed app only accessible via 'localhost'

Hi Joe,

Have you setup a virtual host in the tomcat config server.xml ?
http://tomcat.apache.org/tomcat-6.0-doc/virtual-hosting-howto.html

Sounds like tomcat might not be exposing your app to any host other than localhost.

-Ed


Edward Callahan
Senior MTS
WaveMaker/SpringSource/VMware
===========================
WM 6.4.5, 6.5.M1

Thats what I though Ed, I

Thats what I though Ed,

I looked at that code too but was unsure as to what to put where, is this because the WM deploy is not working and the Tomcat one does not fill in this info? This is the first time I have worked with these programs.

So would this be correct?
Engine name="Catalina" defaultHost="box_ip_address or hostID"
/Engine

Is that added to the defaulHost="localhost" or in place?

Would I need the app dir, this is Windows and I have the app setup and running for the localhost in the webapps dir.

Thanks

I took out the <> as it was giving issue with the posting

Noticed something

Looks like there is no context.xml in meta-inf. Is that required?

I tried another project, I can see that when I drop the war in the webapps folder it expands automatically, which is what is setup. So that is working. Again I can get to it with localhost. I still dont know why the WM deploy is not working.

I tried the engine name and pointed to the app dir, still not working. I tried both replacing and adding a new line, nothing. So I must be doing something wrong with the command.